0%

已经安装Java系统仍继续提示我重新安装

已经安装Java系统仍继续提示我重新安装

您需要安装JDK才能使用“java”命令行工具。

Java官方给出的是这样的答案。

在我更新到 macOS Sierra (10.12)、El Capitan (OS X 10.11) 或 Yosemite (OS X 10.10) 后,为什么系统仍继续提示我重新安装 Java?


本文适用于:

  • 平台: Mac OS X, macOS

故障现象

即使在升级到最新版本的 Java 后,在 macOS Sierra (10.12)、El Capitan (OS X 10.11) 或 Yosemite (OS X 10.10) 上运行某些应用程序时,用户仍会看到一个提示下载 Java 的对话框。

macOS Sierra 10.12 或 Yosemite (OS X 10.10) 消息:

要打开“应用程序”,需要安装旧版 Java SE 6 运行时。
El Capitan (OS X 10.11) 消息:

要使用 “java” 命令行工具,需要安装 JDK


原因

这很可能是因为应用程序需要 Apple 提供的旧版本 Java 6。对于此问题的解决方案,请参阅 http://support.apple.com/kb/DL1572

下载apple提供的低版本Jdk进行安装,然后再安装高级版本,并将高级版本设置为默认。

Mac 修改系统默认Java版本

查看java版本 java -version
jdk目录 /Library/Java/JavaVirtualMachines

先用终端查看当前默认版本,然后到JDK目录查看是已经安装的JDK

JDK目录

复制想要更改JDK版本的目录名称,在终端输入。例如版本为:jdk1.8.0_181.jdk
export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/ export PATH=$JAVA_HOME/bin:$PATH
命令执行完毕后,再执行java -version命令是否将默认版本设置为1.8.0_181

java版本

如果想永久生效,那就把命令加入到你的profile文件中。

echo 'export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/' >> ~/.bash_profile source ~/.bash_profile

你也可以编辑 ~/.bash_profile文件 添加

export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/

效果也是一样的